[WARTE AUF ERW.LOG] Prozent-Anzeige via MQTT springt unter null

- alle Auffälligkeiten, die es zu klären gilt
- Verdacht, dass ein echter Bug vorliegt
Antworten
mrlee
Beiträge: 116
Registriert: Do 10. Mär 2016, 17:56
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 4.xx.xx
Herstellungsjahr: 2012
Robonect-Modul: Robonect H30x (Rev.0)
Robonect Firmware: 1.0b2

[WARTE AUF ERW.LOG] Prozent-Anzeige via MQTT springt unter null

Beitrag von mrlee » Mo 7. Mai 2018, 20:49

Moin!

siehe auch viewtopic.php?f=54&t=1394

Anzeige springt immernoch von 0 auf 100....gefüht schneller :-)

bis denne
Mr.Lee

Admin
Administrator
Beiträge: 1839
Registriert: Di 19. Jan 2016, 18:34
Wohnort: Kiel
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 5.xx.xx
Herstellungsjahr: 2014
Robonect-Modul: Robonect H30x (Rev.2)
Robonect Firmware: 0.9c (WLAN-Test)
Kontaktdaten:

Re: [nicht gelöst] Prozent-Anzeige via MQTT springt unter null

Beitrag von Admin » Di 8. Mai 2018, 16:35

Verstehe ich nicht... Da muss der Mäher dann mehr Blödsinn schicken, als zuvor gedacht. ;-)
Um das zu Bestätigen / ein Work-Around dafür zu schreiben, brauche ich ein erweitertes Logbuch.

Kannst Du, wenn er am springen ist, mal bitte folgendes tun:

http://192.168.2.1/xml?cmd=log&clear aufrufen. (Löscht Logbuch)
http://192.168.2.1/xml?cmd=log&groupoff=65535 aufrufen (Schaltet den erweiterten Aufzeichnungsmodus ein)

Warten bis der Wert einmal hin und her gesprungen ist.

http://192.168.2.1/xml?cmd=log&groupoff=0 aufrufen (Schaltet den erweiterten Aufzeichnungsmodus aus. Das Laden der Seite könnte länger dauern, kann ruhig abgebrochen werden)

Mir das Logbuch schicken. (Download unter Robonect > Service > Download)

Danke!
Bitte alle Benutzer ihre Mäherinformationen direkt im Profil hinterlegen. In der Signatur sind diese dann nicht mehr zwingend erforderlich. :)

minipilot
Beiträge: 45
Registriert: Mi 10. Aug 2016, 09:59
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 4.xx.xx
Herstellungsjahr: 2013
Robonect-Modul: Robonect Hx (Rev.2)
Robonect Firmware: 1.0beta4

Re: [WARTE AUF ERW.LOG] Prozent-Anzeige via MQTT springt unter null

Beitrag von minipilot » Mo 14. Mai 2018, 17:38

Hallo,

hatte selbiges Phänomen. Bilder vom Node-Red hängen an. Erweiterstes Log habe ich nicht, hatte diesen Thread zu spät gesehen. Er hatte sich festgefahren. Rob steht jetzt in der Ladestation. Der Akku im Display zeigte "voll" an. Der Modus zum Zeitpunkt sollte "3" gewesen sein. In der Sofortinfo zeigte der Akku -2xx mAh an. Vielleicht ist der neg. Wert das Problem.
Bildschirmfoto 2018-05-14 um 16.55.26.png
Bildschirmfoto 2018-05-14 um 16.55.26.png (36.01 KiB) 179 mal betrachtet
Robonect_Logbook_20180514173149.xml
(614.75 KiB) 10-mal heruntergeladen
Gruss

minipilot

BTW: Gibts ne übersicht, welcher Modus was bedeutet?
Rob Snyder im grauen Anzug vom R70Li

minipilot
Beiträge: 45
Registriert: Mi 10. Aug 2016, 09:59
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 4.xx.xx
Herstellungsjahr: 2013
Robonect-Modul: Robonect Hx (Rev.2)
Robonect Firmware: 1.0beta4

Re: [WARTE AUF ERW.LOG] Prozent-Anzeige via MQTT springt unter null

Beitrag von minipilot » Di 15. Mai 2018, 14:44

Hi,

passiert auch bei vollem Akku!
Unbenannt.PNG
Unbenannt.PNG (12.78 KiB) 146 mal betrachtet
Vielleicht sollte man die MQTT Werte nicht nur auf 0% - 100% begrenzen, sonder Negative und auch Werte über 100% zulassen

Gruss

minipilot
Rob Snyder im grauen Anzug vom R70Li

pirni
Beiträge: 72
Registriert: Fr 24. Feb 2017, 15:58
Mäher: Gardena R45Li
Firmware des Mähers (MSW): MSW 6.xx.xx
Herstellungsjahr: 2016
Robonect-Modul: Robonect Hx (Rev.3)
Robonect Firmware: 0.0

Re: [WARTE AUF ERW.LOG] Prozent-Anzeige via MQTT springt unter null

Beitrag von pirni » Di 15. Mai 2018, 15:23

Falls Du das hier mit den verschiedenen Modi meinst..
hab das schnell aus meinem Script gezogen

$status_code = array();
$status_code["0"]=" Status wird ermittelt";
$status_code["1"]=" parkt";
$status_code["2"]=" arbeitet";
$status_code["3"]=" sucht die Ladestation";
$status_code["4"]=" lädt";
$status_code["5"]=" sucht (wartet auf Umsetzen)";
$status_code["7"]=" braucht Hilfe - FEHLER!";
$status_code["8"]=" braucht Hilfe - Schleifensignal verloren!";
$status_code["16"]=" ist abgeschaltet";
$status_code["17"]=" schläft";

minipilot
Beiträge: 45
Registriert: Mi 10. Aug 2016, 09:59
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 4.xx.xx
Herstellungsjahr: 2013
Robonect-Modul: Robonect Hx (Rev.2)
Robonect Firmware: 1.0beta4

Re: [WARTE AUF ERW.LOG] Prozent-Anzeige via MQTT springt unter null

Beitrag von minipilot » Di 15. Mai 2018, 16:43

Falls Du das hier mit den verschiedenen Modi meinst..
Jo, DANKE!
Rob Snyder im grauen Anzug vom R70Li

mrlee
Beiträge: 116
Registriert: Do 10. Mär 2016, 17:56
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 4.xx.xx
Herstellungsjahr: 2012
Robonect-Modul: Robonect H30x (Rev.0)
Robonect Firmware: 1.0b2

Re: [WARTE AUF ERW.LOG] Prozent-Anzeige via MQTT springt unter null

Beitrag von mrlee » Do 17. Mai 2018, 19:48

Moin!

So, log ist raus...hoffe ich habe alles richtig gemacht...

bis denne
Mr.Lee

minipilot
Beiträge: 45
Registriert: Mi 10. Aug 2016, 09:59
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 4.xx.xx
Herstellungsjahr: 2013
Robonect-Modul: Robonect Hx (Rev.2)
Robonect Firmware: 1.0beta4

Re: [WARTE AUF ERW.LOG] Prozent-Anzeige via MQTT springt unter null

Beitrag von minipilot » So 27. Mai 2018, 13:41

Meiner ist gerade auch am springen. Ich konnte ein Log ziehen.
Bildschirmfoto 2018-05-27 um 13.40.02.png
Bildschirmfoto 2018-05-27 um 13.40.02.png (23.41 KiB) 2 mal betrachtet

Hoffe es hilft!
Dateianhänge
Robonect_Logbook_20180527133913.xml
(337.86 KiB) 2-mal heruntergeladen
Rob Snyder im grauen Anzug vom R70Li

Antworten

Zurück zu „Bug?“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste