UTF8 error connecting MQTT to Home Assistant

- von Fabian Hader bestätigte Bugs
- von Beta-Testern reproduzierbare Bugs

Nur Moderatoren und Admin können echte Bugs in dieses Forum verschieben.
Gesperrt
magnushq
Beiträge: 1
Registriert: Di 15. Mai 2018, 12:24
Mäher: Husqvarna Automower 105
Firmware des Mähers (MSW): MSW 6.xx.xx
Herstellungsjahr: 2016
Robonect Firmware: 1.0beta4

UTF8 error connecting MQTT to Home Assistant

Beitrag von magnushq » Di 15. Mai 2018, 12:28

When adding MQTT to Home Assistant, the following message appears when Home Assistant is trying to autoconfigure:

Tue May 15 2018 12:17:05 GMT+0200 (CEST)
Can't decode payload b'33 \xb0C' on homeassistant/health/climate/temperature with encoding utf-8

Is this an error in Robonect FW or in Home Assistant?

Benutzeravatar
Andreas
Beiträge: 28
Registriert: Mo 10. Apr 2017, 20:29
Wohnort: Harrislee
Mäher: Gardena R70Li
Firmware des Mähers (MSW): MSW 5.xx.xx
Herstellungsjahr: 2015
Robonect-Modul: Robonect Hx (Rev.3)
Robonect Firmware: 1.0 Beta2 (Bootloader v0.4)
Kontaktdaten:

Re: UTF8 error connecting MQTT to Home Assistant

Beitrag von Andreas » Mi 16. Mai 2018, 00:04

Just a guess, but consider to deactivate the units and only send raw numbers, it looks like there is the "°C" information added right beyond the value, you are interested in.
Vielen Dank und viele Grüße,
Dipl.-Inform. (FH) Andreas Link

Robonect Integration in OpenHAB2 via MQTT

Admin
Administrator
Beiträge: 1839
Registriert: Di 19. Jan 2016, 18:34
Wohnort: Kiel
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 5.xx.xx
Herstellungsjahr: 2014
Robonect-Modul: Robonect H30x (Rev.2)
Robonect Firmware: 0.9c (WLAN-Test)
Kontaktdaten:

Re: UTF8 error connecting MQTT to Home Assistant

Beitrag von Admin » Mi 16. Mai 2018, 15:43

I think Andreas is right.
@Andreas: Should i remove the "°" or should I encode it UTF8?
Bitte alle Benutzer ihre Mäherinformationen direkt im Profil hinterlegen. In der Signatur sind diese dann nicht mehr zwingend erforderlich. :)

Benutzeravatar
Andreas
Beiträge: 28
Registriert: Mo 10. Apr 2017, 20:29
Wohnort: Harrislee
Mäher: Gardena R70Li
Firmware des Mähers (MSW): MSW 5.xx.xx
Herstellungsjahr: 2015
Robonect-Modul: Robonect Hx (Rev.3)
Robonect Firmware: 1.0 Beta2 (Bootloader v0.4)
Kontaktdaten:

Re: UTF8 error connecting MQTT to Home Assistant

Beitrag von Andreas » Mi 16. Mai 2018, 16:22

Admin hat geschrieben:
Mi 16. Mai 2018, 15:43
@Andreas: Should i remove the "°" or should I encode it UTF8?
I think a conversation to UTF8 is in general a good idea for data transported via MQTT, but regarding the initial problem of @magnushq it should be sufficient so simply deactivate the hook as marked in the following picture (sorry I cannot decrease the presented size):
2018-05-16_Robonect_MQTT-Setup_Web-AndreasLink.de.png
MQTT unit deactivation
2018-05-16_Robonect_MQTT-Setup_Web-AndreasLink.de.png (144.8 KiB) 84 mal betrachtet
This will - as a result - only send the plain numbers to the MQTT broker aka Home Assistant and I assume, then it will be happy. --> @magnushq to verify
Vielen Dank und viele Grüße,
Dipl.-Inform. (FH) Andreas Link

Robonect Integration in OpenHAB2 via MQTT

Gesperrt

Zurück zu „bestätigte Bugs“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste