Nach Winterschlaf 0% Lädt...

Nutze einen Akku mit größerer Kapazität um eines der beiden Ziele zu erreichen.
Heisti
sehr erfahrener Forum-Nutzer
Beiträge: 284
Registriert: Di 10. Jul 2018, 14:18
Mäher: Husqvarna Automower 420
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2017
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: -1.0 Beta 7a

Re: Nach Winterschlaf 0% Lädt...

Beitrag von Heisti »

Habe dazu schon einmal einen langen Text geschrieben und jetzt nicht die Zeit das nochmals alles anzuführen.

Die Prozentanzeige für den Akku ist ein virtueller Wert, den sich die Software aus verschiedenen Parametern zusammensucht, um uns irgendwie visuell einen Eindruck zu vermitteln, wie es um unsere Akkus bestellt ist. Weiterhin nutzt die Software des Mähers diesen Wert, um zu entscheiden, wann es Zeit ist wieder in die "Box" zu fahren (noch genügend Treibstoff um nach Hause zu kommen).

Wenn man das verstanden hat, wird einem klar, dass sollte einer der Parameter fehlen, auch die ganze Prozentanzeige nicht mehr stimmen wird. So eine fehlende Info könnte - wie schon angeführt - z. B. die Selbstentladung über den Winter sein oder auch ein neu eingebauter Akku.

Damit die Prozentanzeige wieder "funktioniert", muss der Akku mindestens einmal den gesamten Lade- und Betriebsprozess (Entladung) durchlaufen haben. Das ist quasi wie eine Kalibrierung.

Wenn jetzt z. B. der Mäher im Herbst mit 100% Anzeige in die Garage gestellt wurde, kommt er durch die Selbstentladung im Frühjahr nur noch mit 3/4 vollem Akku wieder raus, zeigt aber immer noch 100% an (die Anzeige ist ja doof und hat nicht bemerkt, dass lange Winterpause war). Die Ladeelektronik merkt aber: halt, die Spannung ist zu niedrig, der Akku muss geladen werden. Das macht sie dann auch und beendet den Ladevorgang (wie bei jedem anderen Gerät auch) über die Ladeschlussspannung (deswegen kann dem Akku nichts passieren und er auch nicht überladen werden). Die Mähersoftware bekommt am Ende des Ladevorgangs die Rückmeldung "nun ist der Akku wirklich voll, und der "Positivwert 100%" stimmt wieder. Das andere Ende (den "Negativwert") kennen wir aber noch nicht und daher muss der Mäher nun erstmal raus. Hier wird sich dann an der entnommene Strommenge orientiert.

Speziell beim Mäher ist nur, dass die Software dafür sorgt, dass der Akku möglichst nur in einem Bereich zwischen (grob) 30% und 70% genutzt wird. Er wird also nie ganz voll geladen und auch auch nie ganz leer georgelt. Dadurch hält er länger und ein alterungsbedingter Kapazitätsverlust wird vom Anwender nicht bzw. erst sehr spät bemerkt. Aber das ist wieder ein anderes Thema und dafür nutzt die Software dann auch wieder den Prozentwert als Referenz.

B.Stromberg
Forum-Nutzer
Beiträge: 48
Registriert: Di 15. Mai 2018, 15:29
Wohnort: NRW
Mäher: Gardena R70Li
Firmware des Mähers (MSW): MSW 6.xx.xx
Herstellungsjahr: 2017 (Modell 2018)
Robonect-Modul: Robonect Hx (Rev.4)
Robonect Firmware: V1.0 Beta 7a

Re: Nach Winterschlaf 0% Lädt...

Beitrag von B.Stromberg »

Ja, bei mir kommt ja erscherend noch hinzu, dass ich einen größeren Akku verbaut habe.
Damit kommt die % Anzeige eh nicht klar...
Weiß nicht ob Fabian da nochmal was dran basteln könnte???

Der Akku hat gut 5 Stunden gebraucht, bis er dann tatsächlich vollkommen voll war.
Einziger Indikator bei meiner Konstellation ist die Spannung.

Der Akku war gestern runter auf 17 Volt. Wundert mich eh, dass ein Li Ionen Akku doch soviel an Spannung in 5 Monaten verliert. Mäher war aus, Robonect ebenfalls....
Lustig war, dass die "%" Anzeige immer mal wieder anfing hochzuzählen.
Der Ladevorgang war letztendlich bei 20,5 Volt beendet.

Hatte den Thread vom Nachbarforum vergessen und war dann doch etwas erschrocken.
Ist aber alles völlig normal.

Der Mäher hat nun heute 5 Std. am Stück gemäht und ist jetzt vorhin wieder in die Ladestation gefahren :)

Heisti
sehr erfahrener Forum-Nutzer
Beiträge: 284
Registriert: Di 10. Jul 2018, 14:18
Mäher: Husqvarna Automower 420
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2017
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: -1.0 Beta 7a

Re: Nach Winterschlaf 0% Lädt...

Beitrag von Heisti »

Denke an der Prozentanzeige im Zusammenspiel mit einem größeren Akku wird Fabian nichts ändern können, weil er die Anzeige nur ausliest und diese von der Mähersoftware vorgeben wird. Das würde nur gehen, wenn er eine eigenen Anzeige kreiert. Aber dafür müsste er auch Zugriff und Einfluss auf das interen Batteriemanagement haben. Und das genau geht nicht. Darum auch diese "Krücken" der manuellen Einstellung der Mähzeitanpassungen.

B.Stromberg
Forum-Nutzer
Beiträge: 48
Registriert: Di 15. Mai 2018, 15:29
Wohnort: NRW
Mäher: Gardena R70Li
Firmware des Mähers (MSW): MSW 6.xx.xx
Herstellungsjahr: 2017 (Modell 2018)
Robonect-Modul: Robonect Hx (Rev.4)
Robonect Firmware: V1.0 Beta 7a

Re: Nach Winterschlaf 0% Lädt...

Beitrag von B.Stromberg »

Ich denke anhand der Spannung könnte das schon gehen.
Wenn man einen Minimumwert (hier 17200 mV =0%) angeben könnte und einen Maximumwert (20500 mV = 100%) würde die "%" Anzeige im Web IF schon korrekt anzeigen.

JA, ich weiß, dass das keine "korrekten" Werte wären.
Sind es beim Original Akku aber auch nicht, da, wie du schon sagtest, der Akku ja nie voll entladen oder voll geladen wird.

Wäre halt cool, wenn man das in den Einstellungen einstellen kann.

Heisti
sehr erfahrener Forum-Nutzer
Beiträge: 284
Registriert: Di 10. Jul 2018, 14:18
Mäher: Husqvarna Automower 420
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2017
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: -1.0 Beta 7a

Re: Nach Winterschlaf 0% Lädt...

Beitrag von Heisti »

Das Thema hatten wir schon einmal. Wenn man den Akku wie vorher auch, nicht 100% nutzen wollte (so wie original), wären dann 100% = 100% oder nur 70/80%?

Und bei deiner Idee setzt du voraus, dass der Akku linear an Spannung verliert. Das tut er aber nicht.

Und es ist das, was ich bereits schrieb. Fabian müsste eine völlig eigenständige Anzeige basteln. Diese müsste dann aber auch alle Parameter berücksichtigen, wie entladene und geladenen Kapazität usw. damit z. B. die Alterungsprozesse des Akkus mit berücksichtigt werden usw..

B.Stromberg
Forum-Nutzer
Beiträge: 48
Registriert: Di 15. Mai 2018, 15:29
Wohnort: NRW
Mäher: Gardena R70Li
Firmware des Mähers (MSW): MSW 6.xx.xx
Herstellungsjahr: 2017 (Modell 2018)
Robonect-Modul: Robonect Hx (Rev.4)
Robonect Firmware: V1.0 Beta 7a

Re: Nach Winterschlaf 0% Lädt...

Beitrag von B.Stromberg »

Hmmm....
Das erklär mir jetzt bitte.

Die Motoren im Mäher laufen, der Ladestrom im WebIF zeigt einen Minuswert an. Solange die Motoren laufen entlädt sich der Akku, ob nun konstant oder nicht spielt doch keine Rolle. In mV kann man dies sehr gut erkennen. Einer Energierückgewinnung durch z. B. Wärme kann man sicher vernachlässigen, die liegt im Promille Bereich.

Der Mäher fährt in die Ladestation. Der Mäher lädt mit konstant mit ca. 1100 mA. Welcher Einfluss sollte hier eine linare Aufladung stören?

Solange der Ladestrom positiv oder negativ anliegt, passiert doch etwas mit dem Akku...
Vielleicht nicht 100% linear aber Anhand der Variablen Ladestrom und Spannung sollte ein halbwegs akzeptabler Prozentwert herauskommen.
Alle Male besser als die permanente "0%"

Klar, der einzige Faktor, der dort einspielen könnte ist das Alter des Akkus, also Verschleiß... Ändert an der Anzeige aber nicht wirklich etwas.

Aber vielleicht stehe ich hier auch völlig auf dem Schlauch??? :mrgreen: :geek:

Heisti
sehr erfahrener Forum-Nutzer
Beiträge: 284
Registriert: Di 10. Jul 2018, 14:18
Mäher: Husqvarna Automower 420
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2017
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: -1.0 Beta 7a

Re: Nach Winterschlaf 0% Lädt...

Beitrag von Heisti »

Die beschreibst wirklich ganz genau die Problempunkte. Die Entladekurve dieser Akkus läuft bei konstanter Stromentnahme eben halt nicht linear. Die Voltzahl geht am Anfang recht schnell runter. Dann hält der Akku sehr lange eine relativ konstante Spannung, bevor es zum Ende hin steil bergab geht. Kennst du evtl. von deinem Handy. Ausschließlich die Spannung dafür zu verwenden führt zu keinen guten Ergebnissen. Eine zuverlässige Anzeige würdest du nur erhalten, wenn du den entnommenen Strom ins Verhältnis zur vorher geladenen Kapazität setzt (plus parallele Überwachung der Spannung).

DEIN Mäher lädt mit 1.100 mA. Meiner z. B. mit knapp 2.000 mA. Aber was willst du mit dem Wert anfangen? Du weißt nur wie hoch der aktuelle Ladestrom ist, aber dir fehlt der Zeitfaktor und damit die echte geladene Kapazität. Und die ändert sich natürlich in Abhängigkeit von Zeit, Temperatur und Zustand (Alter) des Akkus.

Natürlich könnte Fabian das irgendwie mit den vorhandenen Werten und Infos nachbilden. Aber das ist genau das, was ich sagte. Er müsste dann eine eigenständige Auswertung programmieren.

Antworten

Zurück zu „Mähzeit oder Lebensdauer des Akku erhöhen“