Nach App-Update Verbindungsproblem [Gelöst]


Hinweis: Auch wenn eine Android-App im Play-Store nicht mehr zur Verfügung steht, ist die Weiterverbreitung der App ohne Einwilligung des Entwicklers der App nicht legal, auch nicht wenn sie kostenlos angeboten wurde!
Aus diesem Grund wird dies hier nicht geduldet und zur Anzeige gebracht!
jove01
Forum-Nutzer
Beiträge: 25
Registriert: Do 12. Apr 2018, 13:56
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 5.xx.xx
Herstellungsjahr: 2015
Robonect-Modul: Robonect Hx (Rev.4)
Robonect Firmware: -1.02

Nach App-Update Verbindungsproblem [Gelöst]

Beitrag von jove01 »

Hallo
Nach dem Update der App vor 16 Stunden hat die App die Verbindung zu Robonect verloren. Ein Direkter Aufruf der URL funktioniert.

Ich habe auch den R40Li entfernt. beim neu Hinzufügen wird er auch gefunden, aber es kommt dann eine Meldung "Kommunikationsfehler ..."

Verbinde ich mein Handy mit dem Robonect Netzwerk, kommt nicht die IP von Robonect sondern die meines Allgemeinen Netzwerkes.

Und das, obwohl ich alle Daten der App inkl. Cache gelöscht habe.

Campus
sehr erfahrener Forum-Nutzer
Beiträge: 417
Registriert: Mi 27. Jan 2016, 16:08
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 5.xx.xx
Herstellungsjahr: 2012
Robonect-Modul: Robonect H30x (Rev.1)
Robonect Firmware: 1.0beta5

Re: Nach App-Update Verbindungsproblem

Beitrag von Campus »

Hängt RN normal im WLAN? Funktioniert der Zugriff im Browser des Handys?
Gruß
Campus

jove01
Forum-Nutzer
Beiträge: 25
Registriert: Do 12. Apr 2018, 13:56
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 5.xx.xx
Herstellungsjahr: 2015
Robonect-Modul: Robonect Hx (Rev.4)
Robonect Firmware: -1.02

Re: Nach App-Update Verbindungsproblem

Beitrag von jove01 »

Hallo Campus
Ja, normalerweise im WLAN

Ich habe den Zugriff der App im WLAN und im Robonect- Wlan versucht.

Über den Browser (Chrom) konnte ich mich parallel anmelden.

Campus
sehr erfahrener Forum-Nutzer
Beiträge: 417
Registriert: Mi 27. Jan 2016, 16:08
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 5.xx.xx
Herstellungsjahr: 2012
Robonect-Modul: Robonect H30x (Rev.1)
Robonect Firmware: 1.0beta5

Re: Nach App-Update Verbindungsproblem

Beitrag von Campus »

Gibt es noch irgendwelche detaillierteren Fehlermeldungen oder nur das Wort Kommunikationsfehler?

Ich habe gerade noch einen anderen Bugfixes (0.9.55) publiziert, bitte diese Version auch noch einmal testen. Danke!
Gruß
Campus

jove01
Forum-Nutzer
Beiträge: 25
Registriert: Do 12. Apr 2018, 13:56
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 5.xx.xx
Herstellungsjahr: 2015
Robonect-Modul: Robonect Hx (Rev.4)
Robonect Firmware: -1.02

Re: Nach App-Update Verbindungsproblem

Beitrag von jove01 »

Hallo Campus
Ich habe gerade die App aktualisiert. Aber leider Änderung.
Screenshot_2020-06-23-09-57-32-151_com.google.android.apps.photos.jpg
Ich habe den zeitlichen Zusammenhang zum letzten Update, ob das stimmt kann ich nicht beurteilen. Vielleicht mache ich aber auch einen stinknormalen Fehler.

Campus
sehr erfahrener Forum-Nutzer
Beiträge: 417
Registriert: Mi 27. Jan 2016, 16:08
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 5.xx.xx
Herstellungsjahr: 2012
Robonect-Modul: Robonect H30x (Rev.1)
Robonect Firmware: 1.0beta5

Re: Nach App-Update Verbindungsproblem

Beitrag von Campus »

Danke für den Screenshot. Diese Fehlermeldung kommt, wenn die App schon die Socketverbindung zum Mäher nicht aufbauen kann.

Fragen:
- Ist ein Proxy im System konfiguriert?
- Ist eine Firewall im System konfiguriert?
- Läuft auf dem Handy irgendeine andere Art von Sicherheits-/AV-Software die Netzwerkverbindungen analysiert und blockiert?

Ist die Adresse wirklich korrekt und wurde sie von Hand eingegeben oder per Bonjour gefunden? Im Zweifelsfall noch einmal direkt die IP-Adresse manuell eingeben, die der Router für RN anzeigt.
Gruß
Campus

jove01
Forum-Nutzer
Beiträge: 25
Registriert: Do 12. Apr 2018, 13:56
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 5.xx.xx
Herstellungsjahr: 2015
Robonect-Modul: Robonect Hx (Rev.4)
Robonect Firmware: -1.02

Re: Nach App-Update Verbindungsproblem

Beitrag von jove01 »

Hallo Campus

Auf alle Fragen: Nein
Ausnahme App Avira Antivirus

Die IP wurde automatisch gefunden inkl. Port.

Bei der manuellen Eingabe das gleiche.

Hier noch ein Screenshot nach Aufruf der URL
Screenshot_2020-06-23-10-46-56-423_com.android.chrome.jpg

Campus
sehr erfahrener Forum-Nutzer
Beiträge: 417
Registriert: Mi 27. Jan 2016, 16:08
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 5.xx.xx
Herstellungsjahr: 2012
Robonect-Modul: Robonect H30x (Rev.1)
Robonect Firmware: 1.0beta5

Re: Nach App-Update Verbindungsproblem

Beitrag von Campus »

Kann man Avira irgendwie deaktivieren? Es muss irgendetwas dafür sorgen, dass die Netzwerkverbindung richtig geblockt wird, denn der Fehler tritt ganz unten im Netzwerk-Stack auf. Technisch verhält sich die App wie ein Browser, macht exakt das gleiche.
Gruß
Campus

jove01
Forum-Nutzer
Beiträge: 25
Registriert: Do 12. Apr 2018, 13:56
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 5.xx.xx
Herstellungsjahr: 2015
Robonect-Modul: Robonect Hx (Rev.4)
Robonect Firmware: -1.02

Re: Nach App-Update Verbindungsproblem

Beitrag von jove01 »

Ich habe Avira deinstalliert. Gleicher Fehler.

Campus
sehr erfahrener Forum-Nutzer
Beiträge: 417
Registriert: Mi 27. Jan 2016, 16:08
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 5.xx.xx
Herstellungsjahr: 2012
Robonect-Modul: Robonect H30x (Rev.1)
Robonect Firmware: 1.0beta5

Re: Nach App-Update Verbindungsproblem

Beitrag von Campus »

Funktioniert denn die mower.online Adresse? Handy und Mäher sind auch im gleichen WLAN?
Gruß
Campus

Antworten

Zurück zu „Android“