RL40i - Mähauftrag per MQTT wird nicht angenommen, Nur 2 x Doppelpieps am RL40i

Einbindung von Robonect Hx und IO in Deine bereits bestehende MQTT-Infrastruktur
andreas_n
Forum-Anfänger
Beiträge: 3
Registriert: So 21. Okt 2018, 13:12
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 2.xx.xx
Herstellungsjahr: 2011
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: V1.0 Beta7a

RL40i - Mähauftrag per MQTT wird nicht angenommen, Nur 2 x Doppelpieps am RL40i

Beitrag von andreas_n »

Hallo

Nach Einbau von Robonect/Firmware V1.0b7 scheint alles OK zu sein. Kann Daten lesen und zwischen Auto/Manuell umschalten.
Nur gelingt es mit nicht einen Mähauftrag zu erzeugen - oder irgendwie einen Start auszulösen.
Das Kommado wird vom RL40li empfangen - er quittiert dies aber nur mit 2 x Doppelpips.
Der Timerstart arbeitet jedoch und es wird jeden Tag gemäht.

Ich habe wohl alle Möglichkeiten ausprobiert - evt. hat jemand noch eine Idee?

Benutzeravatar
shadowkiller
Forum-Veteran
Beiträge: 3208
Registriert: Do 11. Jan 2018, 08:42
Wohnort: Würzburg
Mäher: Husqvarna Automower 315
Firmware des Mähers (MSW): MSW 10.xx.xx
Herstellungsjahr: 2017 (Modell 2018)
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: 1.2 (Daily Build, WLAN 1.7.4)
hat sich bedankt: 18 Male
wurde gedankt: 4 Male

Re: RL40i - Mähauftrag wird nicht angenommen, Nur 2 x Doppelpieps am RL40i

Beitrag von shadowkiller »

Ich habe es vielleicht nicht ganz kapiert.

Aber Fakt ist: der manuelle Mähauftrag kann immer ausgelöst werden, egal, ob der Mäher im Auto-Modus ist (=mäht nach Timervorgaben), oder nicht.
Anleitung zur Erstinstallation
--
Robonect® Dokumentation und Support
--
Forum cooler nutzen: Hervorhebungen machen und Screenshots posten
--
Es wurde schon alles gefragt, nur noch nicht von allen. (frei nach Karl Valentin)

Admin
Administrator
Beiträge: 2778
Registriert: Di 19. Jan 2016, 18:34
Wohnort: Kiel
Mäher: Gardena SILENO City 500
Firmware des Mähers (MSW): MSW 11.xx.xx
Herstellungsjahr: 2017 (Modell 2018)
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: stets die Allerneuste :-)
hat sich bedankt: 1 Mal
wurde gedankt: 2 Male
Kontaktdaten:

Re: RL40i - Mähauftrag wird nicht angenommen, Nur 2 x Doppelpieps am RL40i

Beitrag von Admin »

Die Firmware deines Mähers hat einen sehr langen Bart. Aber nichtsdestotrotz sollte die V1.0 Beta7 damit kompatibel sein. Letzte Änderungen sind mit eingeflossen.
Kannst Du mal das Logbuch anhängen? (Download über Robonect > Service > Download).
Ich verschiebe dieses Thema mal in das Bug-Forum.
Werbefläche zu vermieten. :lol:

andreas_n
Forum-Anfänger
Beiträge: 3
Registriert: So 21. Okt 2018, 13:12
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 2.xx.xx
Herstellungsjahr: 2011
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: V1.0 Beta7a

Re: RL40i - Mähauftrag wird nicht angenommen, Nur 2 x Doppelpieps am RL40i

Beitrag von andreas_n »

Hatte das Problem fast vergessen. Allerdings ist das Problem noch vorhanden.
Hier das Logfile.
Ich kann den Start nicht per MQTT auslösen.
Ansonsten scheint alles OK zu sein. Im Moment fährt er ganz normal mittels Timer raus.
Gruß Andreas
Zuletzt geändert von andreas_n am So 2. Jun 2019, 20:13, insgesamt 2-mal geändert.

Benutzeravatar
shadowkiller
Forum-Veteran
Beiträge: 3208
Registriert: Do 11. Jan 2018, 08:42
Wohnort: Würzburg
Mäher: Husqvarna Automower 315
Firmware des Mähers (MSW): MSW 10.xx.xx
Herstellungsjahr: 2017 (Modell 2018)
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: 1.2 (Daily Build, WLAN 1.7.4)
hat sich bedankt: 18 Male
wurde gedankt: 4 Male

Re: RL40i - Mähauftrag wird nicht angenommen, Nur 2 x Doppelpieps am RL40i

Beitrag von shadowkiller »

Mach bitte mal einen Screenshot vom manuellen Auftrag nach dem Doppelpieps und vom Akkustand. Danke.
Anleitung zur Erstinstallation
--
Robonect® Dokumentation und Support
--
Forum cooler nutzen: Hervorhebungen machen und Screenshots posten
--
Es wurde schon alles gefragt, nur noch nicht von allen. (frei nach Karl Valentin)

andreas_n
Forum-Anfänger
Beiträge: 3
Registriert: So 21. Okt 2018, 13:12
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 2.xx.xx
Herstellungsjahr: 2011
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: V1.0 Beta7a

Re: RL40i - Mähauftrag wird nicht angenommen, Nur 2 x Doppelpieps am RL40i

Beitrag von andreas_n »

Danke für die schnelle Antwort.
Habe via MQTT den RL40i auf manuell gesetzt -> OK
Danach habe ich ebenso via MQTT den Befehl start abgesetzt -> Doppelpieps
(Habe auch andere Kombinationen ausprobiert-> Konnte den RL40i nicht zur Arbeit bewegen)

Korrigieren muss ich mich bzg des Mähauftrags via Webseite - Der geht doch.

Mittlerweile gewinne ich aber den Eindruck, dass ich den Rasenmäher nicht korrekt mit MQTT ansteuere...
Könnte dies sein?
Zuletzt geändert von andreas_n am So 2. Jun 2019, 20:12, insgesamt 1-mal geändert.

Benutzeravatar
shadowkiller
Forum-Veteran
Beiträge: 3208
Registriert: Do 11. Jan 2018, 08:42
Wohnort: Würzburg
Mäher: Husqvarna Automower 315
Firmware des Mähers (MSW): MSW 10.xx.xx
Herstellungsjahr: 2017 (Modell 2018)
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: 1.2 (Daily Build, WLAN 1.7.4)
hat sich bedankt: 18 Male
wurde gedankt: 4 Male

Re: RL40i - Mähauftrag wird nicht angenommen, Nur 2 x Doppelpieps am RL40i

Beitrag von shadowkiller »

Wenn es per Webseite geht, dann brauche ich auch keinen Screenshot mehr davon ;)
Es muss ja dann an Deiner MQTT-Anbindung liegen. Aber was da nicht funktioniert solltest Du mal dort fragen.
Deshalb verschiebe ich dieses Thema dorthin und benenne es um.
Anleitung zur Erstinstallation
--
Robonect® Dokumentation und Support
--
Forum cooler nutzen: Hervorhebungen machen und Screenshots posten
--
Es wurde schon alles gefragt, nur noch nicht von allen. (frei nach Karl Valentin)

Lampi
sehr erfahrener Forum-Nutzer
Beiträge: 344
Registriert: Di 14. Feb 2017, 17:07
Mäher: Husqvarna Automower 330X
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2014
Robonect-Modul: Robonect Hx (Rev.1)
Robonect Firmware: V1.2 (Final Release)
hat sich bedankt: 1 Mal
wurde gedankt: 1 Mal

Re: RL40i - Mähauftrag per MQTT wird nicht angenommen, Nur 2 x Doppelpieps am RL40i

Beitrag von Lampi »

Bisher habe ich noch nicht versucht einen manuellen Auftrag über MQTT zu starten. Kann ich mal testen, aber leider nicht vor Dienstag. Vielleicht kann dir Fabian aber bis dahin schon anhand des Logbuchs weiterhelfen.
Fragen? Fragen!

Lampi
sehr erfahrener Forum-Nutzer
Beiträge: 344
Registriert: Di 14. Feb 2017, 17:07
Mäher: Husqvarna Automower 330X
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2014
Robonect-Modul: Robonect Hx (Rev.1)
Robonect Firmware: V1.2 (Final Release)
hat sich bedankt: 1 Mal
wurde gedankt: 1 Mal

Re: RL40i - Mähauftrag per MQTT wird nicht angenommen, Nur 2 x Doppelpieps am RL40i

Beitrag von Lampi »

Ich habe es heute mal testen können. Was geht ist das Umschalten der Betriebsart, aber ich bekomme weder ein start noch stop hin. :?:

Daher mal die Frage an die anderen MQTT-User: kann jemand den Mäher über MQTT starten und stoppen?
Fragen? Fragen!

robiChriBa
Forum-Anfänger
Beiträge: 3
Registriert: Fr 23. Nov 2018, 17:39
Mäher: Husqvarna Automower 105
Firmware des Mähers (MSW): MSW 6.xx.xx
Herstellungsjahr: 2016
Robonect Firmware: 1.1b

Re: RL40i - Mähauftrag per MQTT wird nicht angenommen, Nur 2 x Doppelpieps am RL40i

Beitrag von robiChriBa »

Hi.

Die Frage ist zwar schon etwas älter, aber in der 1.1b gehen bei mir START und STOP. Auch die modes funktionieren (HOME, AUTO, MAN, EOD). Wenn ich aber per MQTT einen Job eintrage (Topic robi/control/job: '00:00-18:00' z.B.) dann wir der Job im Webinterface zwar angezeigt, der Mäher fährt aber nicht los. Per MQTT wir mir nach dem Setzen des Jobs erst mode=2 (HOME) gemeldet und ein paar Sekunden später mode=0 (AUTO).

Das Verhalten ist unabhängig vom vor dem Job gesetzten Mode.

Im Webinterface kann ich einen Job setzen und der startet auch.

Noch zur Info: ich verwende den MQTT-Adapter mit ioBroker.

Viele Grüße,
Christian

Antworten

Zurück zu „MQTT-Nutzer“