Webhooks

Fehlt eine Funktion? Dann nur her mit Deinen Ideen!

Wünsche sind Wünsche. Ansprüche bitte an sich selbst richten.
Danke fürs Verständnis. :D

:arrow: Alle Wünsche werden von Fabian gelesen. Eine Erinnerung ist nicht hilfreich!
:arrow: Vor jeder neuen Betatestversion wägt Fabian ab, ob ein Wunsch umgesetzt werden kann oder (noch) nicht.
:arrow: Eine Erinnerung, dass es den einen oder anderen Wunsch schon länger gibt, ist deshalb nicht notwendig und führt dadurch eher nicht zum Erfolg.

:arrow: Nachfragen zu einer Einschätzung der technischen Machbarkeit können natürlich gern an die Foren-Nutzer gestellt werden. Erfahrene Nutzer können aus Erfahrung manches technisch begründen.

- erfolgt keine Antwort, konnte bisher kein Leser seine Einschätzung geben, bitte geduldig bleiben
- eine Reaktion von Fabian äußert sich (neben einer Antwort) entweder dadurch, dass der Wunsch umgesetzt wurde (siehe Changelog im Downloadforum), oder dadurch, dass das Thema in eins der drei folgenden Unterforen verschoben wurde.

:arrow: Beachte bitte die Beschreibungen der Unterforen
Antworten
Skyx3
Forum-Anfänger
Beiträge: 7
Registriert: So 16. Aug 2020, 20:33
Mäher: Husqvarna Automower 305
Herstellungsjahr: 2020
Robonect-Modul: Robonect Hx (Rev.6)
Robonect Firmware: 1.20

Webhooks

Beitrag von Skyx3 »

Hallo

aktuell kann ich via HTTP den Mäher starten, nur leider bekomme ich keine Rückmeldung ob dies auch geklappt hat in meine Automatisierung zurück. Meine Automatisierung unterstützt Webhooks, bedeutet es wäre super wenn ich ähnlich wie beim Pushservice URLs pro Zustand hinterlegen könnte, sprich wenn Robby beginnt zu laden rufe http://xxxx.de/state=1 und wenn er fertig ist mit laden, rufe http://xxxx.de/state=0 auf.

Lampi
sehr erfahrener Forum-Nutzer
Beiträge: 344
Registriert: Di 14. Feb 2017, 17:07
Mäher: Husqvarna Automower 330X
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2014
Robonect-Modul: Robonect Hx (Rev.1)
Robonect Firmware: V1.2 (Final Release)
hat sich bedankt: 1 Mal
wurde gedankt: 1 Mal

Re: Webhooks

Beitrag von Lampi »

Wenn Befehle über API an Robonect gesendet werden kommt auch eine Rückmeldung zurück. Wenn der Befehl erfolgreich ausgeführt werden konnte beinhaltet die Antwort ein "<successful>true</successful>" und wenn nicht erfolgreich kommt ein "<successful>false</successful>" mit Grund warum der Befehl fehlschlug.


Dies kommt z.B. wenn er schon gestart ist und nochmal den Startbefehl bekommt:

Code: Alles auswählen

<?xml version="1.0" encoding="UTF-8" ?><robonect><successful>false</successful><error_code>6</error_code><error_message>Automower already running</error_message></robonect>
Fragen? Fragen!

Skyx3
Forum-Anfänger
Beiträge: 7
Registriert: So 16. Aug 2020, 20:33
Mäher: Husqvarna Automower 305
Herstellungsjahr: 2020
Robonect-Modul: Robonect Hx (Rev.6)
Robonect Firmware: 1.20

Re: Webhooks

Beitrag von Skyx3 »

Hi Lampi

Danke dir für das Feedback, aber leider klappt das nicht, ich kann keine Daten über die Automatisierung einsammeln, ich kann sie nur aktiv von Außen setzen. Sprich ich muss zwingend für die Stati den Wert senden bzw. über Webhooks aufrufen können.

Antworten

Zurück zu „Wünsche“